Frage Mac OS 10.6 (Snow Leopard) und ExpressCard-CF Reader


gromit

Sehr aktives Mitglied
Tach,

normal treibe ich mich ja mehr in anderen Bereichen dieses Forums herum, aber diesmal hätte ich selbst gerne mal eine Frage:

Setzt hier jemand ExpressCard-Reader (vor allem für CF) an seinem MacBookPro ein? Meins hat noch einen, bei den Aktuellen ja nur noch das 17er, leider.

Hintergrund der Frage: Mit SnowLeopard scheint Apple beim Onboard-Programm "Image Capture" (Digitale Bilder) den Support für Expresscard gestrichen zu haben, bei Leopard ging das noch problemlos: Leser einstecken, karte rein, es öffnete sich "Digitale Bilder" und auf Klick wurden meine Bilder auf die Festplatte transferiert. So wird die Speicherkarte zwar als Volume gemounted, aber Digitale Bilder öffnet sich nicht.

Mein Reader ist ein ExpressCard PCIe, nutzt also nicht die USB-Schnittstelle, wie es manche Billigdinger machen.

Es liegt definitiv an SnowLeopard. Wenn ich meinen Firewire-Reader anstecke oder gar die Kamera selbst dranstecke, geht alles wie gehabt, nur eben nicht über den Expresscard Reader, was sehr ärgerlich ist, da ich mir den extra angeschafft habe, um unterwegs kein Kabelgedöns zu haben (und nachdem der USB-CF meine UDMA-Karte nimmer wollte).

Hat jemand hier das gleiche Problem und evtl eine Lösung dafür parat? Google fand ähnliche Problemschilderungen, aber keine Lösung.

BTW: ich bin schon recht lange mit MacOS unterwegs und kenne das System sehr gut, allerdings hat mich dieses Update da wohl kalt erwischt.

Herzlichen Dank im Voraus.
 
W

Wolle

Guest
Moin,

kann Dir leider nicht helfen, da ich zum Importieren meiner Fotos immer den GraphicConverter benutze.
 
Kommentar

gromit

Sehr aktives Mitglied
Moin,

kann Dir leider nicht helfen, da ich zum Importieren meiner Fotos immer den GraphicConverter benutze.
Den hab ich früher auch genutzt, aber inzwischen nimmer. Zwischendurch auchmal die Fuji-Software, aber die eben seit Intelmac nicht mehr, da die immer noch PPC ist.

Es ist wirklich verzwickt, ich finde nichts drüber, daß kein Expresscard mehr unterstützt wird.
 
Kommentar

gromit

Sehr aktives Mitglied
Moin,

Warum nicht?
Weiß nimmer. Graphicconverter war mein Hauptprogramm, als ich noch keine DLSR hatte (schon unter 7.x oder so), bei den ersten beiden hab ich ihn noch weitergenutzt, dann PS CS und inzwischen Lightroom, zwischendurch die Fujisoftware. Digitale Bilder ging schneller, danach wird mit ExifRenamer verschoben und umbenannt. Kann sein, daß das auch im GC geht, hatte aber schon mit Lightroom das Problem, daß das mein Numerierungsschema nicht umsetzen kann, daher die externe Lösung.

GC brauchte recht lange zum Start, in der Zeit hat Digitale Bilder schon einen Teil der Bilder rübergeschaufelt.
 
Kommentar

jazzmasterphoto

Erfahrenes Mitglied
.


Nicht ganz blöde Frage, Dietmar, auch wenn es sich so liest:

Warum kopierst Du nicht einfach den Bilder-Ordner aus dem DCIM-Ordner
an den gewünschten Ort auf Deiner Festplatte?

Und öffnest anschließend mit dem Programm Deines Vertrauens?


.
 
Kommentar

Wuxi

Sehr aktives Mitglied
Ich stöpsele die Kamera direkt ein, oder - was etwas schneller geht und den Akku schont - benutze einen €5 Hama USB reader.

Und dann schiebe ich die Bilder in ein Verzeichnis und importiere Sie von dort in meine Bilddatenbank. (Bzw ich verpointere sie nur. Die Dateien bleiben dort.)
 
Kommentar

gromit

Sehr aktives Mitglied
Warum kopierst Du nicht einfach den Bilder-Ordner aus dem DCIM-Ordner
an den gewünschten Ort auf Deiner Festplatte?

Und öffnest anschließend mit dem Programm Deines Vertrauens?
Warum per Hand machen wenn ich da eine bisher gut funktionierende Automatik habe?

Das hilft mir gerade nicht wirklich weiter. Ich suchte keine andere Arbeitsweise, sondern eine Problemlösung auf Systemebene.
 
Kommentar

jazzmasterphoto

Erfahrenes Mitglied
... eine Problemlösung auf Systemebene.

Dann vertelle ich mal, was ich in so einem Falle täte:

1. Schauen, wie die "Image Capture"-Ordner beim alten Leopard aussahen.
2. Desgleichen beim neuen Snow Leopard.
3. Sorgfältig die Unterschiede im Datei-Bestand feststellen.
4. Sämtliche "Leopard"-Dateien, die bei Snow Leopard nicht vorhanden sind,
erst farbig markieren (dann findet man sie später auch sofort) und sie dann
an gleicher Ordnerstelle im Snow Leopard platzieren.
5. Neustart, Expresscard-Reader einstecken und gucken, was passiert.

Ich vermute, daß im Ordner "System -> Library -> Image Capture", wo vier
Unterordner "Automatic Tasks", "Devices", "Tools" und "TWAIN Data Sources"
liegen, die für Dich entscheidende Datei (oder mehrere) fehlt.

Es könnte aber auch in "Library -> Image Capture" in "Devices" oder
"Scripts" was fehlen ...



Viel Erfolg wünscht

Sven

.
 
Kommentar

gromit

Sehr aktives Mitglied
Kann ich nicht bestätigen. Die Version 7.x ist deutlich schneller als die 6.x . Welche Version hat Du denn?
Auf was für einem Rechner?
ich hab die aktuelle 6.x auf MacMini 2009 und einem 2008er MBP, beide im Bereich 2.2 GHz. Auf die 7.x wollte ich eigentlich nicht aktualisieren, da ich das programm faktisch nimmer nutze und die Vorschau in Adobe Bridge mache.

@Jazzmasterphoto: ja, das wäre auch meine Vorgehensweise gewesen, ich glaube nämlich auch, daß da eine Datei fehlt. Kann aber auch sein, daß es nicht nur die Datei ist, sondern einfach in einer kext der Support dafür ausgebaut wurde. Muß mal eine externe Festplatte mit Leo bestücken, aufm G4 ist noch Tiger drauf und das hat keinen Expresscard, sondern Cardbus, aber das könnte durchaus er gleiche Mechanismus sein, den hab ich dort ja auch schon so eingesetzt.
 
Kommentar

gromit

Sehr aktives Mitglied
Kleines Update:

1. "Digitale Bilder" unter 10.6 hat, wie ich gerade sehen konnte, weniger Funktionalität als vorher. Da ließ sich nämlich ein Prozeß angeben, der nach dem Bilderdownload gestartet wurde.

2. habe ein frisches 10.5 auf einer externen Festplatte installiert, die Karte mitsamt Reader reingesteckt und mich gewundert: nichts passierte! Manueller Aufruf von "Digitale Bilder" erkennt den Expresscard-Reader ebenfalls nicht als Kamera bzw passendes Gerät an (im Menü oben meldet er sich als IDE Controller an).

3. habe das mit 10.4 ausgetattete alte Powerbook G4 gestartet und die Karte mitsamt dem noch vorhandenen PCMCIA-Adapter in dessen Cardbus-Slot gesteckt. Das Volume wurde angezeigt, aber Digitale Bilder nicht geöffnet. Beim Start von Hand aber zeigt es mir die Karte an und schlägt den Import der Bilder vor. Ich kann neben der Auswahl, was bei Anschluß einer Kamera geöffnet wird auch sagen, welcher Prozeß nach Kopieren der Bilder ausgeführt werden soll - genau an dieser Stelle hatte ich dann den ExifRenamer eingetragen. Diese Funktion gibts bereits bei 10.5 nicht mehr, und das 10.5er Programm sieht genauso aus wie das bei 10.6, ich aber hatte bei 10.5 genau das Fenster des 10.4er Programms, somit wurde diese Software beim Systemupdate nicht ersetzt, und zwar auf beiden Rechnern nicht. Sieh an ...

Nachdem aber das aktuelle Programm keinen Prozeß danach mehr starten kann, muß ich mir wohl eine gänzlich andere Lösung suchen oder das alte Programm installieren, was aber sicher Probleme verursachen dürfte.
 
Kommentar

jazzmasterphoto

Erfahrenes Mitglied
... das alte Programm installieren, was aber sicher Probleme verursachen dürfte.

Wieso denn das?
Es gibt noch viel ältere OS X-Programme, die problemlos
mit neueren Systemen funktionieren.

Einfach installieren, die alten Prozesswege angeben und
sehen, was passiert. Löschen kannst Du immer noch ...


.
 
Kommentar

gromit

Sehr aktives Mitglied
Mit dem Installieren des alten Programms wirds fürchte ich nicht getan sein, da der Mechanismus, um eine über Expresscard angesteckte Speicherkarte zu akzeptieren, wohl tiefer im System verankert ist. Die Mass Storage.app habe ich bereits versuchsweise ausgetauscht, aber die wird ja von einem Systemprozeß aufgerufen, und der ist die Ursache. Den hab ich noch nicht rausbekommen.
 
Kommentar
Oben Unten
LiveZilla Live Chat Software