IE-kompatibles Webdesign ohne Tabellen

Thread Status
Hello, There was no answer in this thread for more than 30 days.
It can take a long time to get an up-to-date response or contact with relevant users.

FrankF

Auszeit
Registriert
So sieht die Seite mit bösem Tabellenlayout aus:
http://afrika.net/temp/weinbautest78/startseite_ie7dirty.htm

Und so als w3c-valides XHTML/Strict:
http://afrika.net/temp/weinbautest78/div_pure.html

(Achtung, ich arbeite aktuell an der Seite, wenn temporär andere Fehler auftreten, habe ich mich vertippt, ich schreibe im Texteditor)

Das Problem?

In allen Browsern wird die Seite korrekt dargestellt außer im Internet Explorer, wo der Header mit Navigation unten rechts neben dem Seitenfuß erscheint.

Ich habe den JS-Hack für IE7 von der Seite http://thestyleworks.de ausprobiert, aber der hilft in dem Fall nicht.

Beim Tabellenlayout habe ich die Darstellungsprobleme im IE durch explizites Setzen von cellpadding=0 und cellspacing=0 hinbekommen, auch wenn es sich dabei um Mehrfachdeklarationen handelte.

Wer weiß Rat?

Danke

Frank
 
Anzeigen

AndyE

Sehr aktives NF Mitglied
Registriert
Wo ist das Problem? - schaut irgendwie normal aus.
Das ist das Display des ersten Links im IE7.
LG, Andy

large.jpg
 
Kommentar

FrankF

Auszeit
Registriert
Wie gesagt: Der erste Link zeigt, wie es aussehen soll, ist aber mit dem Vorschlaghammer Tabellenlayout und ohne Beachtung der Webstandards (transitional, d.h. Browser im Quirk-Modus) gezimmert.

Mit der DTD XHTML/Strict will ich die Browser in den W3C-Standard-Modus zwingen, damit die SEite in allen Browsern jetzt und in Zukunft korrekt angezeigt wird.

AndyE schrieb:
Wo ist das Problem? - schaut irgendwie normal aus.
Das ist das Display des ersten Links im IE7.
LG, Andy

large.jpg
 
Kommentar

CALYPTRA

Sehr aktives NF Mitglied
Registriert
Hallo Frank.
Ich habe vor kurzem mal ähnliche Darstellungsprobleme gehabt. Im Firefox gings, im IE7 nicht. Bis ich irgendwann dann darauf gekommen bin, dass der neue IE7 rumzickt, wenn irgendwas mit der HTML Variante nicht stimmt. Konkret hatte ich das falsche .dtd File von der W3C Seite eingebunden. Allerdings arbeite ich momentan noch mit der loose Variante, geholfen hat es aber.
 
Kommentar

lemonstre

Sehr aktives NF Mitglied
Registriert
wenn du den header rauswirfst und die id navigation wie folgt änderst klappt es auch im IE:

#navigation {
position: relative;
top: 0px;

background: url('http://afrika.net/temp/weinbautest78/bk-nav.jpg') no-repeat top;
height: 150px;
width: 800px;
margin: 0;
padding: 0;
}

jetzt fehlt nur noch der navigations hover style für ie...

;)
 
Kommentar

FrankF

Auszeit
Registriert
lemonstre schrieb:
wenn du den header rauswirfst und die id navigation wie folgt änderst klappt es auch im IE:

#navigation {
position: relative;
top: 0px;

background: url('http://afrika.net/temp/weinbautest78/bk-nav.jpg') no-repeat top;
height: 150px;
width: 800px;
margin: 0;
padding: 0;
}

jetzt fehlt nur noch der navigations hover style für ie...

;)


Ich probiere das direkt mal aus.

Der erste eigene Versuch mit Header raus führte dazu, dass der Content unter der Navigation verschwand.

Den IE-Hoover-Style habe ich von dem alten Design noch auf dem Server rumliegen: http://wh-schmitt.de

Herzlichen Dank

Frank
 
Kommentar

FrankF

Auszeit
Registriert
Super!!!!!

http://afrika.net/temp/weinbautest78/div_pure2.html

Ich habe den Entwurf erst mal wieder heruntergenommen, denn ich bastele weiter daran und werde das Ergebnis ins Netz stellen, wenn alle Plugins laufen und die ca. 40 Seiten Content vom alten ins neue Layout übertragen sind.

Danke noch einmal für die schnelle Hilfe

Frank
 
Kommentar
-Anzeige-
Oben Unten